GM GM 94 3.1L VIN T MFI Trouble Code Info

GM

94 3.1L VIN T MFI
13 Oxygen sensor voltage stays between 0.35 and 0.55 volts for 30 seconds when the TPS signal was above 3%. The engine had been running for at least 2 minutes.
14 Coolant temperature sensor signal indicates a temperature of over 275° F after the engine had been running for at least 10 seconds.
15 Coolant temperature sensor signal indicates a temperature colder than -38° F for at least 2 seconds.
16 Charging system voltage was below 8 volts for 5 seconds while engine speed was more than 1000 RPM.
17 PCM did not detect any cam reference pulses for 3 seconds while engine was running.
21 TPS voltage was above 3.8 volts for 5 seconds with engine speed over 600 RPM and throttle steady.
22 TPS voltage was under 0.2 volts for 3 seconds when the ignition was on.
23 Inlet air temperature sensor signal showed an air temperature of -31° F for 4 minutes.
24 Engine speed was greater than 3000 RPM but vehicle speed was less than 5 MPH for 4 seconds with brake not applied.
25 Inlet air temperature sensor signal showed an air temperature of over 297° F for 5 seconds when vehicle speed was greater than 1 MPH.
28 The PCM received a wrong combination of High and Low pulses from the transaxle range switch for more than 10 seconds.
33 MAP sensor voltage was too high for 4.8 seconds when throttle angle was less than 2%.
34 MAP sensor voltage was too low for 3 seconds when engine speed was over 500 RPM and throttle angle was above 3%.
35 Engine idle speed is either 300 RPM above or below the desired idle speed for 50 seconds.
36 PCM did not receive 6 or more 24X (crank reference) pulses per ignition cycle.
37 TCC brake switch signal was not received by PCM when the vehicle speed went from 35 MPH or above (for 10 seconds) and back to 0, four consecutive times.
41 Cam sensor signal was not received for 5 seconds while engine was running.
43 Knock sensor signal was either above 4.6 volts or below 0.84 volts for at least 10 seconds.
44 Oxygen sensor voltage was under 0.25 volts for at least 60 seconds of closed loop operation.
45 Oxygen sensor voltage was over 0.75 volts for 60 seconds in closed loop operation with a throttle angle between 6% and 20%.
51 MEM-CAL error.
52 CALPAK error.
53 ECM sees a battery voltage of more than 16.9 volts when engine speed was above 800 RPM.
54 Fuel pump voltage was less than 7 volts or more than 14 volts for 3 seconds.
72 Speed sensor signal changed more than 45 MPH in 2 seconds when vehicle was not in park or neutral.
75 TPS was at 0% but engine speed was between 1400 and 2000 RPM for three consecutive times.
76 TPS was at 0% but engine speed was between 1400 and 2000 RPM for three consecutive times.
77 TPS was at 0% but engine speed was between 1400 and 2000 RPM for three consecutive times.
82 PCM did not detect any 3X reference pulses during cranking of engine.
90 TCC did not unlock when commanded to OFF. Torque converter clutch slip was between 10 and 40 RPM (full lock would be 0 RPM) for 10 seconds. Throttle angle was over 30% with normal transmission fluid temperature and gear selector in D3 or D4.