GM 93 2.3L VIN A MFI Trouble Code Info

GM

93 2.3L VIN A MFI
13 Oxygen sensor voltage stays between 0.35 and 0.55 volts for 30 seconds after engine had been running for at least 40 seconds.
14 Coolant temperature sensor signal indicates a temperature of over 285° F after engine had been running for at least 2 minutes, or if CTS was shorted to ground.
15 Coolant temperature sensor signal indicates a temperature colder than -38° F for 60 seconds.
16 ECM did not receive 2X pulses while receiving 1X pulses.
19 7X reference signal problem. ECM has detected either too many or too few pulses between sync signal within 4 minutes.
21 TPS voltage was above 4.0 volts for 5 seconds when the MAP sensor signal showed manifold vacuum to be 15 pounds or more, or the TPS voltage was greater than 4.7 volts with throttle closed.
22 TPS voltage was under 0.2 volts for 5 seconds when the engine was running.
23 Inlet air temperature sensor signal showed an air temperature of -40° F after the engine has been running for 5 minutes and 20 seconds.
24 Vehicle was not in park or neutral for 20 seconds when throttle position signal was over 7% with engine speed between 1600 and 3600 RPM and the MAP signal showed low manifold vacuum.
25 Inlet Air Temperature Sensor signal showed an air temperature over 304° F after engine had been running for 5 minutes and vehicle speed was greater than 15 MPH.
26 Quad-driver sense voltage shows a low voltage for 5 seconds when battery voltage should be present or if the sense voltage shows battery voltage for 20 seconds when a low voltage should be present.
27 Quad-driver sense voltage shows a low voltage for 5 seconds when battery voltage should be present or if the sense voltage shows battery voltage for 20 seconds when a low voltage should he present.
28 Quad-driver sense voltage shows a low voltage for 5 seconds when battery voltage should be present or if the sense voltage shows battery voltage for 20 seconds when a low voltage should be present.
33 MAP sensor signal voltage was too high (low vacuum) for 5 seconds when throttle opening was under 12%.
34 MAP sensor signal voltage was too low (high vacuum) for 0.2 seconds when engine speed was under 1200 RPM or when engine speed was over 1200 RPM with throttle opening over 15%.
35 Idle speed was over 175 RPM outside the desired engine speed commanded by the ECM for at least 5 seconds.
41 ECM had received 8 2X reference pulses without receiving any 1X reference pulses.
42 The EST circuit had an open or a ground and the signal did not change when the ECM applied bypass voltage to the ignition module.
43 The ECM did not detect a knock signal during near wide open throttle, or the knock signal was present for 4.5 seconds or more during normal engine operation.
44 Oxygen sensor voltage was under 0.3 volts for 50 seconds of closed loop operation.
45 Oxygen sensor voltage was over 0.75 volts for 50 seconds of closed loop operation.
51 EPROM error.
53 ECM sees a battery voltage of more than 17.1 volts for 0.2 seconds or less than 10 volts for 4 minutes with ignition on.
65 Fuel injector driver current did not reach 4 amps, injectors commanded "ON" longer than the calibrated pulse width and battery voltage was more than 9 volts for 10 seconds.